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MARKING SCHEME 

 

SECTION A: OBJECTIVE TYPE QUESTIONS 

 

Q.(1) Answer any 4 out of the given 6 questions on Employability Skills.                    (4 x 1 = 4) 

(i) Which of the following is more helpful for improving one’s present performance ? 

       (a) Generic feedback   (b) Summative feedback 

  (c) Specific feedback   (d) None of the above  

(ii) Which of the following stress enhances your productivity in terms of output ?  

(a) Distress    (b) Eustress 

(c) Both (a) & (b)   (d) None of the above  

(iii) …………………. feature of Windows 7 allows you to create a copy of data for future use.  

(a) Backup and Restore  (b) Spyware 

 (c) Keylogger     (d) All of the above 

(iv) A……………is attached to a CPU for capturing keystrokes. 

(a) Wire  (b) Key   (c) Keylogger  (d) Hardware 

(v)  Which of the following characteristics should an entrepreneur have ?  

(a) Innovativeness (b) Motivator  (c) Leadership  (d) All of these 

(vi) Which of the following is an advantage of entrepreneurship as a career ?   

(a) Risk  (b) Hard work  (c) Uncertain Income (d) None of these 

General Instructions: 

1. Please read the instructions carefully. 

2. This Question Paper consists of 20 questions in two sections: Section A & Section B. 

3. Section A has Objective type questions whereas Section B contains Subjective type questions. 

4. All questions of a particular section must be attempted in the correct order. 

5. SECTION A - OBJECTIVE TYPE QUESTIONS (24 MARKS): 

i. This section has 04 questions. 

ii. Marks allotted are mentioned against each question/part. 

iii. There is no negative marking. 

iv. Do as per the instructions given. 

6. SECTION B – SUBJECTIVE TYPE QUESTIONS (26 MARKS): 

i. This section has 16 questions. 

ii. A candidate has to do 11 questions. 

iii. Do as per the instructions given. 

iv. Marks allotted are mentioned against each question/part. 
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Q.(2) Answer any 7 questions out of the given 8 questions on Digital Documentation.  

                                                                                                                                              (7 x 1 = 7) 

     (i) A …………. is a model that you use to create other documents. 

(a) Template  (b) Document  (c) Design  (d) Letter 

(ii) Sumit wants to create Table of Contents in his document. Which tab he should use to do so ?   

(a) File tab  (b) Format tab  (c) Insert tab  (d) View 

(iii) Bhabesh wants to know the answer of the blank : “ …………………. controls how images     

       are stacked upon each other or relative to the text.” Answer to his problem.  

(a) Arrangement (b) Alignment  (c) Anchoring  (d) Positioning  

(iv) Gaurav has inserted an image in a document. He wants to remove the unwanted area of the   

      image. Which option of the word processor he will use to complete the task?  

            (a) Clip art  (b) Cut   (c) Crop  (d) None of the above 

     (v) Samyak is working in Writer. He wants to learn the ways to launch the Drawing tool bar, if      

          not available on the interface. Help him to do so.  

(a) View>Toolbars>Drawing   (b) Insert>Drawing  

.(c) Insert>Group>Drawing   (d) View>Group>Drawing  

(vi) Which toolbar is by default placed below the menu bar? 

(a) Title  (b) Formatting  (c) Picture  (d) Standard 

(vii)  What is the shortcut to bring up the style and formatting window in Writer? 

(a) Ctrl+F1  (b) Ctrl+F5  (c) F11   (d) Ctrl+F12 

(viii) Which of the following is used to apply a style to many areas quickly without having to go     

  back to the Styles Deck and double click each time? 

(a) Paragraph Style   (b) Frame Style 

(c) Fill Format mode  (d) Character Style 

Q.(3) Answer any 7 questions out of the given 8 questions on Electronic Spreadsheet.  

                                                                                                                                              (7 x 1 = 7)  

(i) Which of the following is more elaborate form of Goal Seek? 

(a) Subtotal  (b) Scenario  (c) Solver  (d) Consolidate 

(ii) Which of the following is a correct way to refer to a cell in Calc ? 

(a)<Sheet name>.<Row name> (b) <Sheet name>.<Column name>  

            (c) <Sheet name>.<Cell reference> (d) <Column name>.<Sheet name> 

(iii) Reema does not know which sign is used to insert a formula or function in a spreadsheet   

       application. Help her to find the correct option. 

(a) =(Equal to)    (b) ? (Question mark) 

(c) <(Less than)   (d) >(Greater than)  

(iv) Arguments passed to a macro from Calc are always :  

(a)Values  (b) References  (c) Objects  (d) Text 

(v) Shaurya wants to protect the spreadsheet so that no one can make unnecessary changes to it.     

       Which option is used to protect the spreadsheet ?    

   (a) Edit>protect Document  (b) File>Protect Document 

 (c) Tools>Protect Document (d) None of the above 

(vi) Mayank wants to know the difference between reference to a file and to a hyperlink. Answer  

       to his query.    

   (a) In file, /// is used while in hyperlink // is used.   

(b) In file, // is used while in hyperlink /// is used. 

(c) There is no difference. 

(d) None of the above 

(vii) Reena is curious to know as what cells can hold as the individual elements. Answer to her   

        question. 

(a) Text  (b) Number  (c) Formula  (d) All of the above   
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(viii) Deepa wants to know that in interface of spreadsheet software what does A, B, C and so    

         on, are referred. 

(a) Status Bar  (b) Title bar  (c) Column Headers (d) Row Headers 

 

Q.(4) Answer any 6 questions out of the given 8 questions on Database Management System. 

                                                                                                                                              (6 x 1 = 6) 

(i) Which data type shows value in the form of True or False ? 

(a) Boolean  (b) Integer  (c) Real    (d) Text  

(ii) Asterisk (*) symbol in criteria for query stands for : 

(a) Any number of characters   (b) One character   

(c) Zero characters    (d) None of the above 

(iii) Ranjan wants to know the name given to the singular form for data. Help him to find the   

       answer.  

(a) Datus  (b) Datan  (c) Datum  (d) Data 

(iv) Mrunal wants to know the name of the form of DBMS which is due to E.F. Codd of IBM.   

       Answer to her query. 

(a) Codd DBMS (b) RDBMS  (c) Simple DBMS (d) Primary key 

(v) Database servers are referred to as…………………………..  

   (a) Front-ends  (b) Back-ends  (c) Clients   (d) Nodes 

(vi) COMMIT and ROLLBACK commands are of which type ?    

(a) DML  (b) TCL  (c) DDL  (d) DCL 

(vii) Which clause can be used with the SELECT statement in SQL to specify which rows to   

        retrieve from the Table? 

(a) Where   (b) Which  (c) Set   (d) Like 

     (viii) To modify the data type of a column in table, which command and keyword is used? 

(a) Create, change (b) Alter, modify (c) drop, change (d) None  

 

SECTION B: SUBJECTIVE TYPE QUESTIONS 

Answer any 3 out of the given 4 questions on Employability Skills                                (3 x 2 = 6)  

 

Q. (5) Explain any four 7 Cs of effective communication.    

Ans. : Clear information, Complete information, Concise message, Concrete and coherent 

presentation, Correctness of facts, Consideration of the message and the receiver, Courtesy towards 

receiver. 

Clear information : Choosing appropriate words and phrases to convey ideas in the form of a 

message is very important. You need yourself to be fully clear of what exactly your message is, 

what the objective of your message is, and to whom you are going to share it with.    

Complete information : Completeness of information is very important as it brings the desired 

results without additional messages, builds goodwill. Add 5 W’s in your information : who, what, 

when, where, why. 

Concise message : In this world, every person lacks time. Hence, it is necessary to keep the 

message crisp and concise. It adds not only to the efficacy of the message but also saves the 

receiver’s time in understanding it. 

Correctness of facts : Make sure that whatever you communicate is correct to the best of your 

knowledge. This can be ensured by using the right level of language, presenting accurate facts, 

words and figures. 
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Q. (6) Briefly explain any four stress management techniques. 

 

Ans. : Yoga, Meditation, Physical Exercise, Vacations, Taking nature walks 

Yoga : Yoga for breathing exercises is an effective way of dealing with stress. It brings good supply 

of oxygen to your brain.   

Meditation : It helps in enhancing our mindfulness. It bring peace to your mind. 

Physical Exercise :  

Vacations : Good vacation helps us to reconnect with ourselves, operating as a vehicle for self 

discovery and helping us get back to feeling our best.  

Taking nature walks : Taking time out for nature walks too help in reducing your stress level.  

 

Q. (7) Write and explain any four measures to protect your computer.  

 

Ans. : : Measures to Protect Computer 

 Setting up users and password 

 Using secure password 

 Use of protective software 

 Lock of computer 

Hardware safety and Security 

 Computers must be kept clean 

 Should be kept at moderate temperature 

 UPS must be used  

 Aware of key loggers-it is a small piece of hardware that is manually attached to the 

keyboard. It records or captures all your keyboard strokes while typing. 

 Backup and Restore data is a feature of windows 7 in control panel. 

 

Q. (8) Define ‘Entrepreneur’ & ‘Entrepreneurship’. Write and explain any two qualities   

           (characteristics) of an entrepreneur. 

 

Ans. : Entrepreneur is composite of three basic elements : invention, innovation, adaptation 

Purposeful activity, Creative activity, Risk bearing activity, Organising, Gap filling, Dynamic 

process, Initiative taking, Multi dimensional 

Purposeful activity : It s a goal oriented activity. Eac and every enterprise is launched either to earn 

money or to serve the society. 

Creative activity : It is a creative response to change in environment. It involves introduction to 

something new or better. 

Gap filling : it identifies and fill the gaps between what the society needs and what is available. 

Initiative taking ; Entrepreneurship involves taking initiative. 

 

Answer any 4 out of the given 6 questions on Subject Specific Skills.                            (4 x 2 = 8) 

 

Q.(9) Differentiate between Keep Scale and Keep image size options while cropping an image in a  

         document.     

 

Ans. : When Keep scale is selected (default), cropping the image does not change the scale of the 

picture. When Keep image size is selected, cropping produces enlargement (for positive cropping 

values), shrinking (for negative cropping values), or distortion of the image so that the image size 

remains constant. 
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Keep Scale Keep Image 

When keep scale is selected, cropping the image 

does not change the scale of the picture. 

When keep image is selected, cropping produces 

enlargement, shrinking or distortion of the 

image so that the image size remains constant. 

When keep scale is selected, size of the image is 

changes. 

When keep image is selected, size of the image 

does not changes. 

 

Q.(10) What are templates? What are the advantages of using templates? 

Ans. : A template is a document model that you use to create  other documents.  

1. Consistency: Templates help maintain consistency in formatting, layout, and styling 

throughout a document or across multiple documents.  

2. Time-Saving: Templates can significantly reduce the time required to create new 

documents from scratch.  

3. Guidance and Structure: Templates provide a structured framework that guides 

users through the document creation process.  

 

Q.(11) Distinguish between the following with respect to spreadsheets (Answer any one) 

 i. Relative and Absolute Hyperlink 

 ii. Internet Hyperlink and Document Hyperlink 

Ans. :  

Hyperlinks can be used in Calc to jump to a different location from within a spreadsheet and can 

lead to other parts of the current file, to different files or even to websites.  

i.  

Relative Hyperlink Absolute Hyperlink 

A relative link will stop working only if the start 

and target locations change relative to each 

other. 

A absolute link will stop working only if the 

target is moved. 

A relative hyperlink is hyperlink that contains an 

address that is relative to the address of the 

destination file. 

An absolute hyperlink is a hyperlink that 

contains the full address of the destination file of 

the website. 

In relative hyperlink, the files should be in the 

same order. 

In absolute hyperlink, the files can be stored 

anywhere in the system. 

 

ii. Document hyperlinks are used to connect content within a specific document or on a local 

network. While Internet hyperlinks connect content across the global network of the World Wide 

Web. 

 

Q.(12) What is a function in spreadsheet ? What is the formula to refer to the sum of D3 in Sheet3       

              and E5 in Sheet2.  

Ans. : Functions are pre defined formulae in Calc. It helps us to calculate with the help of formulas.  

  =Sheet3.D3 + Sheet2.E5  

 

Q.(13) Explain any four advantages of DBMS.  

Ans. : Database Management System. It is collection of inter related data and a set of programs to 

access those data.  
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Advantages : Sharing of data, Data redundancy, Data inconsistency, Confidentiality, Highly 

securable  

Sharing of data : Different users can use the same database to access the data according to their 

needs. 

Data redundancy : It means duplication of data. It avoids duplication of data and ensures that there 

is only one instance of certain data. 

Data inconsistency : It helps to avoid data inconsistency. It means if a single database is used by 

multiple users then it also ensures that the same data is present for all the users.  

Confidentiality : It can ensure different views for the different users of the database. This keeps the 

confidentiality of the data safe. 

 

Q.(14) Define Referential integrity with example. Explain different types of relationship between   

            tables by giving suitable example of each.   

Ans. : Referential integrity refers to the relationship between tables. Because each table in a 

database must have a primary key, this primary key can appear in other tables because of its 

relationship to data within those tables. When a primary key from one table appears in another 

table, it is called a foreign key. It means the reference from a row in one table to another table must 

be valid. It requires that a foreign key must have a matching primary key or it must be null.   

 

There are three types of reletionships which can be created in tables : 

(a) 1:1 (one to one) : : In this relationship, both the tables must have primary key columns. Eg. 

Roll number to address  

(b) 1:n (one to many) : In this relationship, one of the tables must have primary key column. It 

signifies that one column of primary key table is associated with all the columns of 

associated table. Eg. Student to subjects/teachers  

(c) m:n (many to many) : In this relationship, one of the tables must have primary key column. 

It signifies that all the columns of primary key table is associated with one column of 

associated table. Eg.  Student and class teacher  

 

Answer any 4 out of the given 6 questions on Subject Specific Skills.                          (4 x 3 = 12) 

 

Q.(15) What is a style ? Explain different types of styles which can be provided in a Writer. 

Ans. : It is a combination of font effects, colours and background such that it can be saved and 

applied whenever needed into the writer document. Writer come with predefined styles for all 

document types. It has five style categories : 

(i) Paragrapg style : It affect entire paragraphs represented with those styles. 

(ii) Character styles : It affect a block of text inside a paragraph. 

(iii) Frame style : It affect frames and graphics 

(iv) Page styles : It affect page formatting (page size, margin and link) 

(v) List styles : It affect outlines, numbered lists and bulleted lists. 

 

Q.(16) What are the advantages of grouping drawing objects ? How can you group different       

            drawing objects in a document ? How can you ungroup them ? Write steps. 

Ans. : Grouping drawing objects make it easier to handle several objects as a single entity, while 

preserving their relative size and positions. When objects are grouped any editing operations carried 

out on that group are applied to all members of the group. If we click on one member of the group, 

the whole group is selected. 
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To group different drawing objects-First select all the object by pressing shift key-> Right click -> 

select group option or  

After selecting the object-> Go to Format menu-> select Group option. 

Select object with Shift key 

Click Format>Group>Group OR Ctrl+Shift+G OR Right click and select Group from context 

menu. 

Ungroup : 

Click on any one object 

Click Format>Group>Ungroup OR Ctrl+Alt+Shift+G OR Right click and select Ungroup from 

context menu. 

 

Q.(17) Anshita is preparing spreadsheet notes for her term exam. Help her to write short note on the   

            following. Give suitable example of each. 

(a) Subtotals  (b) Consolidating data   (c) Goal seek 

Ans. : 

(a) Subtotals : The subtotal feature in spreadsheet helps to use statistical functions (sum, average, 

count, min, max, product) on the group of data repeatedly in one column. It helps to manage, 

analyse and extract specific information from the data. 

(b) Consolidating data : We can summarise data from multiple worksheets into one worksheet or 

master worksheet. The consolidated worksheet can be in the same workbook or can be on another 

workbook. If you have consolidated it, you can update one or more workbook, the updating will 

automatically be reflected in the consolidated workbook. 

(c) Goal Seek : Goal Seek is the process of finding the correct input value when only the output is 

known. 

Tools-> Goal Seek 

 

Q.(18) What are the options available in the Show Changes dialog box while reviewing changes in   

            spreadsheet ? Explain. 

Ans. : Date, Author, Range, Comment, Show Accepted Range, Show Rejected Range 

Date : Only changes made in a certain time range are displayed 

Author : Only changes made by a specific author are displayed. 

Range : Only changes made in a specific range of cells are displayed. 

Comment : Searches the content of the comments and only displays changes which have comments 

that match the search criteria. 

Show Accepted Changes : Only changes you accepted are displayed. 

Show Rejected Changes : Only changes you rejected are displayed. 

 

Q.(19) Your friend owns a chemist shop, he needs to keep records of the medicines with their id’s,   

            date of purchase, expiry date, price, etc. in a database program. But he does not have any  

            knowledge about the Database. Explain to him the following to get a better understanding of  

            the DBMS concepts.  

i. What is DBMS? Explain in brief.  

ii. Name any two database programs which can be used to create a table and store the data as    

    per the requirement.  

iii. Which field can be set as a Primary Key?  

Ans. : - i. A Database is a collection of Records and a set of programs to access those data. 

The management system is important because without the existence of some kind of rules and 

regulations it is not possible to maintain database. 

ii. Examples of Database Management Systems program are MySQL, MS Access, Oracle, MySQL 

Server etc 

iii. Unique field can be set as primary key. Here, id’s can be made as a primary key. 



CL_X_MID TERM_IT(402)_MS_ 8 / 8 
 

Q.(20) Consider the following table : Employees 

Table : Employees 

 

Employee ID Name Gender Salary 

A24092 Bharat Kumar Male 25800 

B23076 Ashish Koorella Male 24900 

B24017 Kevin Caesar Male 32000 

A23094 Krunal Prabhat Male 35300 

C221 Shabhya Jain Female 32500 

B22001 Rinki Mishra Female 34000 

 

(a) Fields : 4 (Employee ID, Name, Gender, Salary) Records : 6 

(b) Write SQL commands for the following : 

(i) Select * from Employees; 

(ii) Select Name, Gender from Employees where Salary>30000; 

  

 

*********** ALL THE BEST ************ 


